Einleitung

Ein kleine Anleitung für das einfache Backup-Programm. Bitte beachten Sie, dass Abbildungen leicht abweichen können.

20.02.2013 Andrea Marschner

MiniBup ist ein einfach zu bedienendes Daten-Sicherungsprogramm für Windows, welches aktualisierte Dateien auf ein Sicherungsmedium kopiert. Ausserdem erstellt es Archiv-Versionen von Dateien – dass heisst, Sie können auch auf ältere Versionen eines einzelnen Dokumentes zurückgreifen. Die jeweils aktuelle Verzeichnisstruktur wird gespiegelt, gelöschte oder verschobene Dateien wandern ins Archiv.

Als Sicherungsmedien kommen alle Datenträger in Frage, die sich von Windows-Explorer aus ansprechen lassen, wie zum Beispiel (externe) Festplatten, USB-Memory-Sticks oder auch Netzlaufwerke.

Sie müssen diese Dokumentation nicht unbedingt vollständig lesen. MiniBup ist möglichst einfach gehalten und ich glaube, viele Leute werden es bedienen können, ohne hier je einen Blick hineinzuwerfen. Allerdings kann sie natürlich trotzdem für das ein oder andere Aha-Erlebnis sorgen - so hoffe ich doch...

Wichtig ist vorallem:

= Erfolg! = Fehler!

Eigenschaften

  • Dient der Datensicherung (simples Kopieren, kein Verifizieren!)
  • Einzelne Ordner/Dateien können ausgeschlossen werden
  • Kann direkt von einem (Netz-) Laufwerk gestartet werden, benötigt keine Installation
  • einfache Archivierungsfunktion
  • Backupintervall einstellbar
  • Wiederherstellung geschieht manuell mittels Windows-Explorer (Programmunabhängigkeit!)

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation

Copyright © 2012 by Andrea Marschner. All Rights Reserved.


Einrichten

MiniBup muss nicht installiert werden, es kann nach Belieben irgendwo hin kopiert werden (wobei auch nichts dagegen spricht, im Programmverzeichnis einen Ordner dafür anzulegen). Wird es gestartet, legt es im Benutzerverzeichnis unter AppData\Roaming\MiniBupData eine Konfigurationsdatei und Protokolldateien an.

Wenn Sie das Programm das erste mal starten, erscheint eine kleine Dialog-Box welche die wichtigsten Einstellungen für Sie zusammen fasst (sie kann auch via Menü „Bearbeiten“ - „Standard Jobs dazu“ geöffnet werden):

Mit Klick auf „Ziel“ wählen Sie das Backup-Medium aus, welches verwendet werden soll. Dazu eignet sich am besten eine interne oder externe (USB-) Festplatte oder auch ein USB-Memory-Stick. Allerdings sind USB-Memory-Sticks in der Praxis meist langsamer als Festplatten – und vor allem haben sie weniger Platz für Daten...

Erstellen Sie darin unter Umständen einen separaten Ordner, zum Beispiel Namens "Backup", damit Sie wissen, wo Sie Ihre Daten finden können. Vermeiden Sie aber zu lange Dateipfade, da Windows grundsätzlich keine längeren Pfadnamen als ca. 260 Zeichen zulässt - bedenken Sie, dass die Verzeichnisstrukturen der Quelle ins Ziel übertragen werden...

Klicken Sie abschliessend auf „OK“, wird Ihnen das Programm ein Backupset erstellen, welches für die meisten Anwender ausreichen wird. Sollten noch andere Verzeichnisse vorhanden sein, müssen diese anschliessend manuell hinzugefügt werden! Für Systeme, welches von mehreren (Windows-) Benutzern verwendet wird, muss die Einstellung gegebenenfalls für jeden Benutzer wiederholt werden!

Wird „Abbrechen“ gewählt, erscheint der Dialog beim nächsten Start wieder. „Abbrechen – Backups nicht automatisch hinzufügen“ deaktiviert ihn – das entspricht dem Deaktivieren der Option im Menü: „Bearbeiten“ - „Std.Jobs autom. dazu“.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Backup starten

"Start" führt die (mit Haken) markierten Jobs sogleich aus:

Das Blinken des gelben Symbols und diverse Informationen geben einen Eindruck vom Ablauf der Sicherung. Die erste kann unter Umständen lange dauern, abhängig von der Menge der Daten. Ein wiederholtes Ausführen wird dann jedoch wesentlich schneller vonstatten gehen, da nur noch geänderte Dateien kopiert werden müssen.

Beim Fortschritt sieht man die Anzahl verarbeiteter Dateien. Bei wiederholtem Ausführen wird auch ein Prozentwert angezeigt, welcher sich auf die Anzahl Dateien im Verhältnis zum letzten Mal bezieht - nicht auf die Grösse der Dateien, welche kopiert werden müssen - deshalb stimmt diese Angabe nicht immer - sie gibt aber in der Regel einen brauchbaren Hinweis auf das Voranschreiten.
Darunter ist der Name der aktuellen Datei sichtbar, der grüne Balken zeigt, wieviel von ihr schon kopiert ist (besonders bei grossen Dateien).
Die "Meldungen"-Liste zeigt die Verzeichnisse, aus denen Dateien kopiert werden. Sie wird gespeichert und steht beim erneuten Programmstart wieder zur Verfügung - immer für den aktuellen Monat. Ältere Dateien können via Menü "Datei" - "Logverzeichnis" auch später noch eingesehen werden. Erst nach ca. einem Jahr werden sie von dort gelöscht.

Backup automatisch starten

Es empfiehlt sich, das Backup regelmässig durchzuführen - bestenfalls automatisch. MiniBup bietet dafür keine eigenen Funktionen, kann aber mit den Hilfsmitteln von Windows entsprechend eingerichtet werden. MiniBup bietet dafür folgende Parameter:

Parameter

  • /S
    Kopieren bei Programmstart ausführen. Eine Zahl gleich dahinter, beendet das Programm nach dem Kopieren:
    /S30 - 30 Sekunden nach dem Kopieren beenden
  • /P
    Poweroff aktivieren (entspricht der Option "Herunterfahren im Programm"): Der PC wird nach dem Backup herunter gefahren. Um den PC nach Abschluss möglichst problemlos herunter fahren zu lassen, wird empfohlen alle anderen Programme vorher zu beenden!
  • /M
    Minimiert starten: MiniBup wird nicht mit normalem Fenster geöffnet, sondern gleich minimiert, das heisst man sieht nur noch das Symbol neben der Uhr von Windows.

Methode Autostart

...ist die einfachste, zuverlässigste Möglichkeit. Man erstellt in Windows ein Verknüpfung von MiniBup (Rechtsklick auf das Programmsymbol und "Verknüpfung erstellen"). Dann öffnet man den Autostartordner vom aktuellen Benutzer (Rechtsklick auf "Alle Programme"-"Öffnen"):

Den entsprechenden Unterordner wählen und die Verknüpfung in diesen Ordner verschieben:

Mittels Rechtsklick "Eigenschaften" der Verknüpfung öffnen und unter "Ziel" die Parameter /S1000 und /M eingeben (siehe oben). Mit "OK" bestätigen.

Nach dem nächsten Anmelden an Windows, startet MiniBup ohne weiteres Zutun unauffällig als Symbol. Nach einer gewissen Verzögerung (in der Regel 20 Sekunden) wird das Backup ausgeführt. Danach bleibt das Symbol noch für die 1000 Sekunden stehen (knapp 17 Minuten) und zeigt durch die Symbolfarbe den Erfolg oder Misserfolg an... (siehe auch in dieser Hilfe unter "Rückmeldungen").

Methode Ausschalten

Funktioniert ähnlich wie "Autostart", aber man erstellt einfach eine Verknüpfung auf dem Desktop von Windows und gibt die Parameter /S /P ein. Anstatt den PC nach getaner Arbeit herunter zu fahren, doppelklickt man die Verknüpfung - MiniBup macht das Backup und beendet Windows anschliessend.

Wichtig bei dieser Methode: Man muss daran denken und gelegentlich auch die Protokolle kontrollieren...

Alternativ lässt man den Parameter /S weg, führt die Kontrolle jeweils gleich durch und startet dann das Backup manuell (Knopf "Starten").

Methode Windows Taskplaner

Ist die Lösung für Rechner, welche dauernd oder unüberwacht in Betrieb sind. In Windows 7 findet man die "Aufgabenplanung" in der Systemsteuerung unter "Verwaltung". Dort gibt es auch einen Assistenten, welcher einen bei der Erstellung einer entsprechenden Aufgabe unterstützt. Sinnvolle Parameter zum Einrichten von MiniBup wären zum Beispiel /S30 /M ...

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Rückmeldungen

Wichtig für ein Backup: Es muss kontrolliert werden! Es liegt im Interesse des Benutzers, dies zu tun... MiniBup bietet dafür etliche Möglichkeiten. Die einfachste ist sicher die "Ampel":

= Backup erfolgreich [image] = es traten Fehler auf [image] = nichts gemacht / blinkend: Backup im Gange

Diese Ampel wird auch im Systeminfobereich angezeigt. Am Besten wird Windows so eingestellt, dass dieses Symbol immer angezeigt wird (via "Anpassen").

⇒

Bitte beachten Sie, dass wenn MiniBup minimiert wird, es von der Taskleiste verschwindet - durch Klick auf dieses Symbol lässt es sich wieder hervor holen...

Nach einem Backup wird in den "Meldungen" immer eine Zusammenfassung angezeigt, welche über den (Miss-) Erfolg orientiert:

Unter "Fehler" sieht man genaueres - unter Hinweisen erscheinen weniger wichtige Meldungen (welche auch kein rotes Symbol auslösen).

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Fehlermeldungen

Rückmeldungen ››

Unter "Fehler" können Sie die Ursache eruieren, weshalb eine Datei nicht kopiert werden konnte. Mithilfe dieser Meldungen sind Sie in der Lage Probleme zu beseitigen. Folgend finden Sie einige Bespiele mit Tipps, was Sie unternehmen können...

Die Fehler-Beschreibungen die hier zu sehen sind stammen von Windows (zum Teil).

Pfad sehr lang! (256) Zeichen D:\Users\am\Purebasic\Datei\MiniBup\diverses\_Deep_Folder 123456789 123456789 123456789 123456789 123456789\123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789\123456789 123456789 123456789 123456789 1234567
Verzeichnis-Pfade dürfen in Windows max. 247, Dateipfade höchstens 259 Zeichen lang sein...
Konnte Verzeichnis<D:\Users\am\Purebasic\Datei\MiniBup\diverses\_Deep_Folder 123456789 123456789 123456789 123456789 123456789\123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789\123456789 123456789 123456789 123456789 1234567> nicht untersuchen!

-> kürzen Sie den Pfad in Ihrer Quelle!

Kopierfehler: D:\Users\am\AppData\Roaming\Nvu\Profiles\98gxgvjh.default\parent.lock (Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.)

-> Schliessen Sie das Programm, welches die Datei blockiert

Kopierfehler: D:\Users\am\AppData\Local\Microsoft\Internet Explorer\Recovery\Active\{73924133-AAF1-11E0-BBB0-F46D04966C89}.dat (Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.)

-> Systemdateien die von Windows benutzt werden lassen sich nicht kopieren - normalerweise ist ein Backup unnötig, fügen sie die Datei, oder gleich das ganze Verzeichnis zu den Ausschlüssen des Jobs (einfach den Text aus dem Fehlerlog kopieren (STRG-C) und in "Ausschlüsse" einfügen (STRG-V)) - in Zukunft werden somit natürlich keine Fehler mehr auftreten:

Das folgende ist weniger gut, da das Kopieren einer Datei und die Wiederherstellung der letzten Archivdatei nicht klappte. Dies hat zur Folge, dass diese Datei im Backup fehlt (im Archiv befindet sie sich noch). Dies tritt übrigens immer in Kombination mit einem Kopierfehler auf.

"Wiederhestellung von Archivdatei hat leider nicht geklappt: ... nach ..."

-> Ist die Datei wichtig, sicherstellen, dass sie kopiert werden kann.

Kopierfehler: X:\BUP\WT\PC-Management\Image Software\pgbr_free_2012g.iso (Die Anforderung konnte wegen eines E/A-Gerätefehlers nicht ausgeführt werden.)

-> Windows Rechtsklick auf Laufwerk, "Eigenschaften", "Tools", "Prüfen" drücken oder CHKDSK ausführen. Versuchen Sie die Datei mit dem entsprechenden Program zu öffnen. Treten dabei Fehler auf, ist die Datei wahrscheinlich defekt - es bleibt dann nur noch sie zu löschen und eine frühere Version aus dem Backup (oder dem Archiv) zu holen. Wurde noch kein Backup erstellt, ist die Datei verloren...

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Hinweise

Rückmeldungen ››

Unter "Hinweise" werden Meldungen ausgegeben, welche nicht so tragisch sind und deshalb auch keine Fehlermeldung generieren (-> nicht Rot).

Folgendes "sollte" eigentlich nicht vorkommen - jedoch sieht die Praxis aus unerfindlichen Gründen manchmal trotzdem so aus:

Achtung, nicht kopiert - Zieldatei ist neuer: X:\BUP\SSD\Star Wars - The Old Republic\SWTORLaunch.dll

oder

"Achtung, nicht kopiert - Quelldatei trägt zukünftiges Datum: ..."

-> Wenn es Bedenken gibt, ob die Datei im Ziel tatsächlich neuer sein könnte: Klären Sie dies ab!

Wenn es sicher ist, dass die Datei im Ziel überschrieben werden kann, entfernen Sie alle Haken, ausser des Jobs mit dem entsprechenden Ziel und führen Sie "IT-Job (... FORCE)" aus. Dabei überschreibt die Datei aus der Quelle auf jeden Fall die im Ziel - und sollte anschliessend folglich ein korrektes Datum haben.

"Wiederhestellung von alter Archivdatei misslungen: ... nach ..."

-> Ist nicht so tragisch, weil es die älteste Archivdatei ist und sie noch existiert (mit der Endung ".arc2del"). Erst beim nächsten Archiv-Vorgang wird diese Datei gelöscht.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Manuelles Einrichten

Im Menü „Bearbeiten“ gibt es einige Punkte um Jobs zu erstellen oder zu ändern:

  • „Job hinzufügen“ fügt einen neuen unterhalb des aktuell gewählten ein
  • „Job löschen“ löscht den aktuell gewählten
  • „Job hoch“ oder „Job runter“ bewegt den gewählten Job in der Liste. Dies hat einen Einfluss auf die Reihenfolge der Ausführung: die oberen werden zuerst ausgeführt.
  • „Ausnahmen suchen“ sucht in der Quelle des ausgewählten Jobs nach bekannten Verzeichnissen, welche normalerweise nicht gesichert werden müssen (dies wird übrigens auch bei den „Standard Jobs“ gemacht) und ergänzt diese im Job.

Mit einem Doppelklick auf einen Eintrag...

...kann man den Job bearbeiten:

  • Bei „Quelle“ kann angegeben werden, was zu sichern ist.
  • Bei „Ziel“ stellt man ein, wohin es gesichert werden soll.
  • Archivieren -> siehe unter "Archivieren"
  • Backup-Intervall gibt an, wann ein Backup erneut ausgeführt werden darf. 0 heisst jederzeit, 1 einmal pro Tag usw. - dies ist vorallem beim automatischen Start mit Windows eine praktische Einstellmöglichkeit. Bitte beachten: Das ist kein Planer, es muss dafür gesorgt werden, dass MiniBup gestartet wird, ob manuell oder automatisch (Windows Autostartordner, Startskript... im Zusammenhang mit Windows Taskplaner machte es Sinn das Intervall auf 0 zu stellen).
    Stichzeit ist 00:00 Uhr (Standard, kann in Konfigdatei geändert werden). Das heisst, wird zum Beispiel ein Backup um 23:55 Uhr ausgeführt, könnte bei einem Backupintervall von 1 das nächste schon um 00:00 Uhr stattfinden...

Theoretisch können hunderte von Jobs erstellt werden, in der Praxis wird das aber nicht praktikabel sein, da das Design für einige wenige Jobs gedacht ist. Es gibt auch eine Programm-technische Obergrenze... ( > Milionen)

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Archivieren

Manuelles Einrichten ››

Wenn "Archivieren" gesetzt ist im Backupjob ("Anzahl Versionen"<>0): Eine vorhandene Datei im Zielverzeichnis wird nicht überschrieben, sondern in einen Archivordner verschoben ("@" im Zielverzeichnis). Ausserdem wird der Name um einen Zähler erweitert. Dateien und Verzeichnisse, welche nur noch im Backup existieren, werden ebenfalls ins Archiv verschoben.

Durch das Archivieren hat man auch immer 1:1 Spiegelung seiner Daten - Aufräumaktionen wie Löschen, Umbenennen oder Verschieben von Dateien und Verzeichnissen werden auf diese Weise übernommen. Der "Schrott" sammelt sich im Archiv.

Man kann angeben, wieviele "Anzahl Versionen" einer Datei im Backup-Archiv erhalten werden sollen. "Archiv-Intervall" gibt dabei an, nach wie vielen Tagen eine Datei im Backup nicht mehr überschrieben, sondern in das Archivverzeichnis verschoben werden soll...

Auf diese Weise kriegt man eine sogenannte Backup-Hystorie seiner Dateien, das heisst man kann auch auf ältere Versionen einer Datei zurück greifen. Mit dem Intervall und der Anzahl kann man den Zeithorizont und den Raster des Backups definieren.

Mit den beiden Einstellungen Intervall und Anzahl kann man steuern, wie detailiert und wie gross ein Backup werden soll. Die Standard-Vorgabe von 3x7=21 Tage dürfte für die meisten Benutzer ausreichend sein:

Normalerweise werden Dateien kaum täglich geändert. Dadurch führt der Raster von 7 Tagen bei geänderten Daten häufig zu einer Archiv-Version. Die Version im Backup entspricht der letzten Laufzeit des Backups. Der benötigte Speicherplatz ist einigermassen gering, es existieren maximal 4 Dateien im Backup. Man hat immer eine bis zu 21 Tage zurückliegende Momentaufnahme der Datei verfügbar.

Für anspruchsvollere Benutzer müssen die Einstellungen evtl. geändert werden: Der Raster von 7 Tagen ist relativ gross für tägliche Bearbeitung - man kann bis zu 7 Tage Arbeit verlieren. Dieser Fall tritt dann auf, wenn eine Datei intern "zerstört" wird, durch Benutzer- oder Programmfehler (also eher ein relativ seltener Fall), ansonsten hat man natürlich immer die aktuellste Version im Backup ausserhalb des Archives.

Ändert man die Variabeln zum Beispiel auf ein Tag Intervall und 21 Versionen, hat man bei gleichem Zeithorizont zwar mehr Versionen zu Verfügung, benötig aber entsprechend mehr Backup-Speicherplatz.

Ein Beispiel für "interne Zerstörung" (Einstellung Intervall 7, Anzahl 3): In Outlook wird eine Mail versehentlich gelöscht. Da Outlook alle Daten in einer einzigen Datei speichert, fehlt bei der nächsten Sicherung dieses Mail auch im Backup. Ist die Löschung gleich nach Erhalt passiert, ist das Mail natürlich auch nicht im Backup. Wäre es erst nach 7 Tagen gelöscht worden, wäre es noch für eine Weile im Archiv zu finden. Nach 21 Tagen wird wohl die letzte Archiv-Version überschrieben, da Outlook meist täglich benutzt wird, wird es auch regelmässig gesichert.

Anmerkung zum Archivieren: Wenn sich grosse Datenbestände häufig ändern, kann diese Funktion den Backup-Datenträger ziemlich schnell füllen! Dies gilt im speziellen für Programme wie zum Beispiel Mailprogramme (Outlook, Outlookexpress, LiveMail, ThunderBird etc.) oder auch Datenbankprogramme. Für solche Daten kann via "Mehr..." eine abweichende Einstellung gemacht werden.

Einen neuen Pfad gibt man in die Zeile "Pfad" ein, Intervall und Anzahl in die folgenden Felder. Die Option "rekursiv" heisst, dass auch untergeordnete Verzeichnisse diese Einstellung verwenden werden. Nun drückt man "Neu" und unten wird eine entsprechende, neue Zeile eingefügt.

Um Änderungen vorzunehmen, klickt man zuerst auf die zu änderne Zeile, ändert die Einstellungen in den Feldern und drückt abschliessend "Ändern".

Will man eine ganze Zeile löschen, wählt man sie aus und drückt "Löschen".

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Ausschlüsse

Manuelles Einrichten ››

Ausschlüsse können in der Dateiliste (2) mit Rechtsklick auf einen Eintrag hinzugefügt oder entfernt werden. In der Spalte "EXCL" wird dies angezeigt (XXXX ist ein Ausschluss, oooo enthält einen).

Die Ausschlüsse können auch im Editorfeld (1) links von Hand bearbeitet werden - so ist es auch möglich, ganze Datei- oder Pfadgruppen auszuschliessen (zBsp .TEMP würde alle Temporärdateien ausschliessen). Seien Sie aber vorsichtig mit solchen Änderungen... (zBsp. Datei.temparatur.txt würde auch ausgeschlossen). Ausschlüsse ohne kompletten Pfad werden im Explorerfenster rechts ggfs. nicht angezeigt!

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Technische Hinweise

Eine Datei wird kopiert wenn das Datum der Quelldatei aktueller als das der Zieldatei ist... Um Unterschieden in den Dateisystemen von FAT und NTFS entgegen zu wirken, werden folgende Zeitdifferenzen ignoriert:

  • <=2 Sekunden (FAT speichert das Datum ungenauer wie NTFS)
  • genau 1 Stunde (NTFS ändert das Datum während der Sommer-/Winterzeit)

FAT32: kann offenbar nicht mit Spezialzeichen umgehen - Jesse=Jessê - dies führt zu Kopier und Archiv-Fehlern...

Abzweigungspunkte (engl. "File System Reparse Points", "Junctions") werden ignoriert!

MiniBup unterstützt keine langen UNC-Dateipfade >260 Zeichen - dies ist eine Einschränkung der Windows API... man kann auch im Explorer nicht auf solche Pfade zugreifen...

Ab 2038 wird der Datumsvergleich nicht mehr funktionieren (http://2038bug.com/)

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation